1 (edited by dimkalinux 2012-02-12 09:22)

Topic: PunBB 1.4.2

PunBB 1.4.2 offers its better visual design and many bug fixes


  • Oxygen style is updated.

  • Errors are translatable.

  • The link from the last part of breadcrumbs is removed.

  • "Last edited message" is moved to the post header.

  • Flash messages is automatically disabled in the case of a redirect with delay > 0.

Bug Fixes

  • Fixed non-updated info block of the last registered user.

  • Fixed redirect of a post to the previous one after its deleting.

  • Fixed upload of avatars in open_basedir cases.

  • Fixed censoring functions. Thanks to Gargaj for helping.

  • Fixed all known "Full-path disclosure" errors.

  • Fixed extension of an updated subsystem - broken in 1.4.0.

  • Fixed broken update in SQLite.

Auto-suggest username from the email inserted in the registration form.

For developers
New function to start  a session - forum_session_start().

No there are "changed only files" in this release because all files altered according to Copyright date updating.

punbb-1.4.2.zip (MD5 4d76707be8cd07c9470ab46e7d31a4a6)


Known errors
You can not install extensions with maxtestedon version 1.4RC* or lower. This bug affect very small set of extensions.

Re: PunBB 1.4.2

Congrats! big_smile


Re: PunBB 1.4.2

¿Changes un the lang?
Congrats for the version of course, the style is really good and the uptades are great
How do I upgrade from version 1.4.1?

Re: PunBB 1.4.2

The language changes can be found in the development board, and just replace the files of your forum with the one from the packages. When you try to access your forum, it will say the database is outdated. Just click on ok and it will upgrade the database for you. smile

Re: PunBB 1.4.2

Is there a change log? I can update the copyright date on my own, but I don't want to overwrite files I don't have to.  (too many edits.)

Re: PunBB 1.4.2

Full changelog available on GitHub - v1.4.1...v1.4.2.

Re: PunBB 1.4.2

sorry, is there a list of the files that have been changed 1.4.1 -> 1.4.2?

Re: PunBB 1.4.2

https://github.com/punbb/punbb/compare/ … les_bucket

Re: PunBB 1.4.2

Nooo... extensions not work sad

Re: PunBB 1.4.2

Please, specify extensions that stop working.

Re: PunBB 1.4.2

In 1.4.2 release we make harder way for installing oldest extensions that not updated and not tested in 1.4.
In default configuration you can not install extensions that have maxtestedon version lower than 1.4.

If you want disable extensions version checking - just add to your config.php this line.



Re: PunBB 1.4.2

http://punbb.informer.com/forums/topic/ … ncy-image/

Re: PunBB 1.4.2

Fancy Image 0.9.6 worked on PunBB 1.4.2.



Re: PunBB 1.4.2

Yea, Thanks !!!


Re: PunBB 1.4.2

Which version of fancy_jquery_addons you have on http://punbb.org.ua/punbb/viewtopic.php?pid=222#p222?

Re: PunBB 1.4.2

Fancy jQuery Addons 2.2.2.


Re: PunBB 1.4.2

I cant install Fancy jQuery Addons 2.2 sad

This extension is not compatible with your PunBB version.

Re: PunBB 1.4.2


Thank you, dimkalinux.

Is there an error with height in Oxygen.min.css?


Re: PunBB 1.4.2

Progent, i think it css-hack for IE or Opera.


Re: PunBB 1.4.2


How i can translate punbb on my language ?

Re: PunBB 1.4.2

Just use English lang files as start point.


Re: PunBB 1.4.2


我的博客 Pnnk.net


Re: PunBB 1.4.2

AOAS, we do not understand in Chinese.
Someone does not understand in Russian.
So we say here in English


Re: PunBB 1.4.2

@dimkalinux Invite system dosen't work on punBB 1.4.2 pun_invitation_only

Re: PunBB 1.4.2

AOAS, 簡單的覆蓋工作。但是,備份文件和數據庫。