Topic: PunBB 1.4.3

PunBB 1.4.3 has been released!

Most significant changes:

  • The default Oxygen theme now supports responsive design.

  • Added the OpenSearch plugin.

  • Added the check for versions of dependent extensions.

  • Added processing AJAX requests.

Other changes:

  • Blocked password reset for Administrator.

  • Added the check for max length of email subjects.

  • Constants have been put into a separate file.

  • Updated LABjs to version 2.0.3.

  • Fixed redeclared clean_conf_names.

  • Fixed interaction with the extension repository.

  • Fixed hardcoded max_subject_length.

  • Fixed the possibility to insert incorrect social network addresses into profiles.

  • Fixed some function calls incompatible with new PHP versions.

  • Fixed some misprints.

  • Added some hooks.

Download
punbb-1.4.3.zip

Changed files only
punbb-1.4.3-changed_files.zip

2

Re: PunBB 1.4.3

Love you!

However, I encountered a bug with the responsive menu. On smarphones, tablets and PCs with smaller screen everything works fine, but on my 23-inch monitor I get something like this:
http://s24.postimg.org/8xt29swqd/zrzut_ekranu1.png

After clicking "PunBB Forums" above the menu, it backs to normal.

Firefox 38, Linux.

3

Re: PunBB 1.4.3

Finally something moving out here!
Thank you very much punbb!

Yours, Benny.

4 (edited by Goodsie 2015-06-15 22:52)

Re: PunBB 1.4.3

This is fantastic news!

Now for the wants wink
One thing I have always wanted is the ability to place an image inline.
ie: when posting and uploading an image,
     have the option of it being placed in the message as an image and not a link.

That aside, it is great to see some activity in this corner smile

Thank You.

Edit::

After getting to play around some I have found that when trying to update a user profile it complains of:
   
Warning! The following errors must be corrected before your profile can be updated:

    You entered an invalid LinkedIn account.

There never was one before and is not now. I was altering the 'title' field of the user profile.
not a super huge issue, just so it's known wink

Re: PunBB 1.4.3

Wowww!!

This is the best news for me in this year smile
At least we have new updates for PunBB!!

Thank you for giving new updates for us o(>_<)o

6

Re: PunBB 1.4.3

However, I encountered a bug with the responsive menu. On smarphones, tablets and PCs with smaller screen everything works fine, but on my 23-inch monitor I get something like this:

Press Ctrl+F5 to reload the new CSS files.

Forex Strategy Builder - the world fastest backtester, generator, optimizer...
Using PunBB since 2006 at Forex Forum

Re: PunBB 1.4.3

What about compatibility with php5.6?

Re: PunBB 1.4.3

Goodsie wrote:

After getting to play around some I have found that when trying to update a user profile it complains of:
   
Warning! The following errors must be corrected before your profile can be updated:

    You entered an invalid LinkedIn account.

There never was one before and is not now. I was altering the 'title' field of the user profile.
not a super huge issue, just so it's known wink

Thank you for the bug report.
We've fixed this error. You can get the actual version of the file from GitHub - profile.php
We are working on PunBB 1.4.4 now, where this error will be fixed, as well.

Re: PunBB 1.4.3

Wow cool news!

Re: PunBB 1.4.3

"I hear the message well, but lack of faith."

Thx for that great news but what does it mean (after some years of non active development)?

Think you've heard about FluxBB2/Flarum and I'm not sure what's the right way. There are some forks too.

I need a forum with garanted long time support not only some sporadic actions ... maybe you can provide some more informations about this.

Re: PunBB 1.4.3

It's great to see PunBB is still being updated!  Keep up the great work!

12

Re: PunBB 1.4.3

I don't know why, but after update (I think) links in this topic doesn't work:
http://punbb.informer.com/forums/post/149596/#p149596

BTW, thanks Popov, I forgot about this trick big_smile.

13

Re: PunBB 1.4.3

This patch is not used.
http://punbb.informer.com/forums/topic/ … or-php-55/

+ http://punbb.ru/post44426.html#p44426

Parserus - BBCode parser
I speak only Russian  :P

Re: PunBB 1.4.3

Slavok wrote:

Thank you for the bug report.
We've fixed this error. You can get the actual version of the file from GitHub - profile.php
We are working on PunBB 1.4.4 now, where this error will be fixed, as well.

Thank you

Re: PunBB 1.4.3

Спасибо! Можете написать интеграцию punbb и dle? Готов оплатить вашу работу!

16 (edited by nova636 2015-06-23 11:44)

Re: PunBB 1.4.3

I am still using 1.4.2, I have tryed, but I can't find out how to upgrade to 1.4.3, may I seek some help?

Do anyone know whether there is any document on how to upgrade punbb?

Thank you!

Re: PunBB 1.4.3

Yes, I also have a problem with the update 1.4.2 to 1.4.3

18

Re: PunBB 1.4.3

Make a backup, replace old files with new one and run the installer.

Re: PunBB 1.4.3

Yes I did, the message "The file 'config.php' already exists which would mean that PunBB is already installed. You should go here instead."

20

Re: PunBB 1.4.3

/admin/db_update.php

Parserus - BBCode parser
I speak only Russian  :P

Re: PunBB 1.4.3

Unfortunately it does not help. I get a blank page. Only restore files runs the forum. 1.4.2 sad

22

Re: PunBB 1.4.3

Check if everything was uploaded correctly. What FTP client do you use? If FileZilla you have listed all files which hasn't been uploaded. If that doesn't help, try to disable all extensions before update.

Re: PunBB 1.4.3

I will remain forever spinning previous version. Nothing can be done sad

24

Re: PunBB 1.4.3

Look in the server error log.

Parserus - BBCode parser
I speak only Russian  :P

Re: PunBB 1.4.3

I do not know how to do it