Topic: Deprecated: preg_replace()... Error

I am receiving the following error message: Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/globalch/public_html/ducktopia/forums/include/parser.php on line 791 Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/globalch/public_html/ducktopia/forums/include/parser.php on line 791

This message occurs when saving a user's signature and remains on the user's page. If you leave the user's profile the error message goes away.

Here is a screenshot provided for you convenience.
http://i.imgur.com/uxt1Bcn.png

Thanks

Re: Deprecated: preg_replace()... Error

http://punbb.informer.com/forums/topic/ … -above-54/

Parserus - BBCode parser
I speak only Russian  :P

Re: Deprecated: preg_replace()... Error

I see this post was made in January 2015. I just created a forum using punBB and am having the same deprecated problem. Has anyone found a solution? I don't have a clue what Moderator Visman is talking about. Is this forum really this messed up?

Re: Deprecated: preg_replace()... Error

This is exacly, what I have corrected. If you want to use php >= 5.5, you have to:
1. Download branch 1.4-next
https://github.com/punbb/punbb/archive/v1.4next.zip
2. Replace these files:
admin/extensions.php
include/cache.php
include/dblayer/pgsql.php
include/parser.php
moderate.php
viewtopic.php

Have you tried this way?

5 (edited by PanBB.Ru 2016-02-05 06:31)

Re: Deprecated: preg_replace()... Error

Your version punbb 144?

Re: Deprecated: preg_replace()... Error

This part in the .next include/parser.php   (line 803)

$text = preg_replace($pattern, $replace, $text);

still throws

Deprecated: preg_replace() [function.preg-replace.php]: The /e modifier is deprecated, use preg_replace_callback instead in

at me...
any idea, anyone?

EDIT:
It was
Fancy Video Tag 0.4.9
that was causing the problem.
Now solved...

Re: Deprecated: preg_replace()... Error

Shateiel,
This works perfectly. the Deprecated message is gone. Thank you.

This is exacly, what I have corrected. If you want to use php >= 5.5, you have to:
1. Download branch 1.4-next

Now, Can you help with three more problems? I have 1.4.4 running. The edit toolbar is missing from Write Messages and Quick Response, my users are not able to post photos (this is a photography forum so this is serious :-)), and I cannot send a global email to all users.

If you have a patch/fix for any of these three I would be eternally in your debt. I would even buy you a coffee the next time you are in Monmouth, Oregon.

SA

Re: Deprecated: preg_replace()... Error

@sanchell
1) are you using extensions that may be interferring?

2) instead of global mail  to all users, you could post message
/admin/settings.php?section=announcements
while you sort out the issue... ?

Re: Deprecated: preg_replace()... Error

Thank you, KeyDog. I think I've got it sorted out.

10

Re: Deprecated: preg_replace()... Error

Hi everyone, I just install new site and got error: no problem when view forum, but view topic it's show error: Warning: preg_replace_callback() [function.preg-replace-callback]
http://i.imgur.com/c8OEh96.jpg
My site installed on php v5.2 host

11

Re: Deprecated: preg_replace()... Error

Update your expansions for PunBB v.1.4.4.

Parserus - BBCode parser
I speak only Russian  :P

12

Re: Deprecated: preg_replace()... Error

Visman wrote:

Update your expansions for PunBB v.1.4.4.

thanks for your reply, do you mean "expansion" is this:

keeshii wrote:

This is exacly, what I have corrected. If you want to use php >= 5.5, you have to:

1. Download branch 1.4-next
https://github.com/punbb/punbb/archive/v1.4next.zip

2. Replace these files:
admin/extensions.php
include/cache.php
include/dblayer/pgsql.php
include/parser.php
moderate.php
viewtopic.php

good luck smile

I read that him use php>5.5, while my host is php 5.2 ?

13

Re: Deprecated: preg_replace()... Error

"expansion" is this:

Open Administration → Extensions
look  Installed extensions

Parserus - BBCode parser
I speak only Russian  :P

14

Re: Deprecated: preg_replace()... Error

Visman wrote:

"expansion" is this:

Open Administration → Extensions
look  Installed extensions

thanks again! So you mean expansion is "extansion" - but...

Visman wrote:

Update your expansions for PunBB v.1.4.4.

it's seem i have nothing to update, all of my exts are supported for v1.44
http://i.imgur.com/kSfMiK6.jpg

15

Re: Deprecated: preg_replace()... Error

the 2nd pic for my extensions
http://i.imgur.com/A9249qE.jpg

16

Re: Deprecated: preg_replace()... Error

the 3rd pic for my ext
http://i.imgur.com/C47aCI7.jpg
I dont see any of them needs to be update ?

Re: Deprecated: preg_replace()... Error

on my forum I had the same problem with the extension SC WYSIWYG. it uses an outdated e\ modifier

18

Re: Deprecated: preg_replace()... Error

PanBB.Ru wrote:

on my forum I had the same problem with the extension SC WYSIWYG. it uses an outdated e\ modifier

do you have any suggestion for my case (not e\ modifier)
I just install new site and got error: no problem when view forum, but view topic it's show error: Warning: preg_replace_callback() [function.preg-replace-callback]
http://i.imgur.com/c8OEh96.jpg
My site installed on php v5.2 host

19

Re: Deprecated: preg_replace()... Error

Reduce the version of your Punbb to 1.4.2 or Switch off all extensions relating to bbcode.

P.S. Switch off them on one and check operation to find problem extension.

Parserus - BBCode parser
I speak only Russian  :P

20

Re: Deprecated: preg_replace()... Error

PanBB.Ru wrote:

on my forum I had the same problem with the extension SC WYSIWYG. it uses an outdated e\ modifier

Uh..Oh..! thanks for your reply
Your comment suggested me to disabling the "sc_wysiwyg", the problem solved.
But now, lots of BBcode are malfunction, exp: size, font, right (alignment)...

21

Re: Deprecated: preg_replace()... Error

Visman wrote:

Reduce the version of your Punbb to 1.4.2 or Switch off all extensions relating to bbcode.

P.S. Switch off them on one and check operation to find problem extension.

thanks! the problem was caused by "sc_wysiwyg"
I wonder why nobody report this in that extension topic ?

22 (edited by PanBB.Ru 2016-05-23 10:25)

Re: Deprecated: preg_replace()... Error

The authors have created an excellent extension. But no longer support them.. I see no reason to use them. Either fix the problem yourself
I have not delved into the issue of expansion. Maybe someday and try to fix it ...  smile