Topic: Changing url of the forum

Hello,

I cannot find in the administration panel where I can change the url of the site.
When I installed the forum, I specified an address as a subfolder of the main site and I want now an address as a sub-domain.
The sub-domain is now created, it is redirected to the proper folder. But when I enter the sub-domain, the address in the address bar is changed to the old address (sub-folder)

Is it possible to modify the url ? I did not find how in the administration panel. Should I modify anything in the root htaccess ? Must I re-install the forum ?

A little help is welcome, please.

Thank you in advance.

http://revest.legtux.org/
PunBB 1.4.4
PHP: 7.2.2-1+0~20180205160612.18+jessie~1.gbpb78b58
Base de données    SQLite3 3.8.7.1

Re: Changing url of the forum

you in config.php rename $base_url ??

Re: Changing url of the forum

Well thanks for your answer, I did not know where to look.

1st url was : mysite.com/forum, I want it as forum.mysite.com

I just modified config .php, but it does not change a thing : the url with sub-domain keeps being redirected to url with sub-folder.

My data base in sqlite3.

http://revest.legtux.org/
PunBB 1.4.4
PHP: 7.2.2-1+0~20180205160612.18+jessie~1.gbpb78b58
Base de données    SQLite3 3.8.7.1

4 (edited by PanBB.Ru 2016-06-26 19:41)

Re: Changing url of the forum

open file config.php in root
rename variable
$base_url = 'http://mysite.com/forum';
on
$base_url = 'http://forum.mysite.com';


PS: if your forum created as mysite.com/forum

Re: Changing url of the forum

It's what I entered, but it does not work.

http://revest.legtux.org/
PunBB 1.4.4
PHP: 7.2.2-1+0~20180205160612.18+jessie~1.gbpb78b58
Base de données    SQLite3 3.8.7.1

Re: Changing url of the forum

you have created a subdomain within the site . Create at the beginning of it in CPanel.

then open the htaccess file and add the line:

RewriteCond %{HTTP_HOST} ^developer\.panbb\.ru$ 
RewriteCond %{REQUEST_URI} !/developer/ 
RewriteRule ^(.*)$ /developer/$1 [L]

Re: Changing url of the forum

Yessss !!!
You are the best ! The problem was with the sub-folder. I moved the forum at the root of my hosting place, on the save level as the main site. It seems to be in working order now. I changed only the url in config.php. And I did not need to modify the htaccess file. That could have been necessary to redirect my numerous users to the new url. But it is still in beta-test and there are only 5 of us. I will just have to modify the url of the pictures and we are nearly ready to make the forum public.
Thanks to your help.

http://revest.legtux.org/
PunBB 1.4.4
PHP: 7.2.2-1+0~20180205160612.18+jessie~1.gbpb78b58
Base de données    SQLite3 3.8.7.1