Topic: Would a PHP 4.3.0 requirement be a problem?

If PunBB 1.3 were to require PHP 4.3.0 or later, would that be a problem for you?

"Programming is like sex: one mistake and you have to support it for the rest of your life."

Re: Would a PHP 4.3.0 requirement be a problem?

No (PHP version 4.4.0)

Re: Would a PHP 4.3.0 requirement be a problem?

No, I would be fine with that (PHP v4.3.11)

4

Re: Would a PHP 4.3.0 requirement be a problem?

my host  PHP 4.4.0

If your people come crazy, you will not need to your mind any more.

5

Re: Would a PHP 4.3.0 requirement be a problem?

My Debian server is at 4.3.10, my host is at 4.4.0.

I don't think that would pose a problem, except for hosts that aren't very security minded.

Re: Would a PHP 4.3.0 requirement be a problem?

That would be fine
Just curious though, why? tongue

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

7

Re: Would a PHP 4.3.0 requirement be a problem?

My host is PHP: 4.3.11

Re: Would a PHP 4.3.0 requirement be a problem?

No problem, I use PHP  in 4.4.0 ....:D
and I saw most webhosting use 4.3.x , so I think it would be ok.

9

Re: Would a PHP 4.3.0 requirement be a problem?

no problem for me. 4.3.11

Ludo,

Re: Would a PHP 4.3.0 requirement be a problem?

Smartys wrote:

Just curious though, why? tongue

Well, if I know that PunBB is running on 4.3.0 or later, I can remove some code here and there and make things a bit simpler. Password hashing can rely completely on sha1(), no need to reimplement get_file_contents() or var_export() etc.

"Programming is like sex: one mistake and you have to support it for the rest of your life."

11

Re: Would a PHP 4.3.0 requirement be a problem?

It will not satisfy everybody but the vast majority will profit from that I think.
And those still stuck with php < 4.3. will have a good reason for a serious talk with their host smile

The German PunBB Site:
PunBB-forum.de

12

Re: Would a PHP 4.3.0 requirement be a problem?

My host is PHP: 4.3.11

[img]http://www.krook.me/play/patrik.php[/img]

Re: Would a PHP 4.3.0 requirement be a problem?

Yeah, as long as all the scripts support <4.3.0 the hosts won't upgrade. Only those who are security minded, which are not that many XD

Re: Would a PHP 4.3.0 requirement be a problem?

running debian stable, so no problem for me ... (4.3.10)

Re: Would a PHP 4.3.0 requirement be a problem?

4.3.11 on my host.

Parimal Satyal - Powermetal from Nepal

Re: Would a PHP 4.3.0 requirement be a problem?

Rickard wrote:
Smartys wrote:

Just curious though, why? tongue

Well, if I know that PunBB is running on 4.3.0 or later, I can remove some code here and there and make things a bit simpler. Password hashing can rely completely on sha1(), no need to reimplement get_file_contents() or var_export() etc.

Aha smile

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

Re: Would a PHP 4.3.0 requirement be a problem?

Done.

"Programming is like sex: one mistake and you have to support it for the rest of your life."

Re: Would a PHP 4.3.0 requirement be a problem?

I guess I am the only one running 5.0.5 smile

Re: Would a PHP 4.3.0 requirement be a problem?

I am on my dev machine smile

"Programming is like sex: one mistake and you have to support it for the rest of your life."

Re: Would a PHP 4.3.0 requirement be a problem?

MyPunBB runs 5.0.5 tongue