51

Re: PunBB 1.2.11

Greatz

Yours, Benny.

Re: PunBB 1.2.11

How to roll up version from 1.2.10 to 1.2.11 for guyz who edited by hand?

Re: PunBB 1.2.11

tassoman wrote:

How to roll up version from 1.2.10 to 1.2.11 for guyz who edited by hand?

Go to the extras folder in the zip archieve, get the x_to_y_update.php.

Edit line 31 and add '1.2.10' to the array
Edit line 32 and replace with $update_to = '1.2.11';

Upload, run and then remove the script.

Re: PunBB 1.2.11

Strofanto wrote:
tassoman wrote:

How to roll up version from 1.2.10 to 1.2.11 for guyz who edited by hand?

Go to the extras folder in the zip archieve, get the x_to_y_update.php.

Edit line 31 and add '1.2.10' to the array
Edit line 32 and replace with $update_to = '1.2.11';

Upload, run and then remove the script.

What are you talking about? tongue
Download a copy of PunBB, look in the extras folder, there's a 12_to_1211_update.php file. Upload it to your forum directory, run it, delete it tongue

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

Re: PunBB 1.2.11

Wouldn't be almost done upgrading option in mysql database, by phpmyadmin? o_O?

Re: PunBB 1.2.11

Smartys wrote:

What are you talking about? tongue
Download a copy of PunBB, look in the extras folder, there's a 12_to_1211_update.php file. Upload it to your forum directory, run it, delete it tongue

You lazy tongue

Re: PunBB 1.2.11

tassoman wrote:

Wouldn't be almost done upgrading option in mysql database, by phpmyadmin? o_O?

That too if you feel more comfortable with PHPmyAdmin.

Re: PunBB 1.2.11

Strofanto wrote:
Smartys wrote:

What are you talking about? tongue
Download a copy of PunBB, look in the extras folder, there's a 12_to_1211_update.php file. Upload it to your forum directory, run it, delete it tongue

You lazy tongue

As opposed to what? PunBB is already set up to work without editing the file

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

Re: PunBB 1.2.11

I assume he did the changes manually so he didn't bother to download the new version from the website, therefore his update.php script was actually outdated, probably to 1.2.10.

Re: PunBB 1.2.11

What makes you assume he kept his copy of PunBB somewhere? tongue

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

Re: PunBB 1.2.11

Nothing, I just assumed, if he doesn't keep any shame on him. tongue

62

Re: PunBB 1.2.11

Smartys wrote:

What makes you assume he kept his copy of PunBB somewhere? tongue

lol that's good

Here's what may be a stupid question.  With 1.2.11, auto-registration by the scripts will still happen, but there can only be a maximum of 1 per hour?  Or did I misunderstand?

Re: PunBB 1.2.11

You're correct, but it surely will discourage scripts =/ And it won't crash the server.

Re: PunBB 1.2.11

Rickard wrote:

Here's a short message announcing 1.2.11. This release has been made primarily to address an issue with the registration script that allowed a malicious user to perform a denial-of-service attack. PunBB 1.2.11 adds code to the registration script that prevents these flood registrations (an hour has to pass between registrations from the same IP). On top of this, an XSS vulnerability has been addressed.

For those of you not afraid to edit the scripts manually, here are the two changes:

http://dev.punbb.org/changeset/336
http://dev.punbb.org/changeset/335

Thanks to the people who alerted me via e-mail about the circulation of an "exploit" for the DoS attack.

how kan i installe it

PunBB, the FluxBB of tomorrow - today!

Re: PunBB 1.2.11

grudon66 wrote:
Rickard wrote:

Here's a short message announcing 1.2.11. This release has been made primarily to address an issue with the registration script that allowed a malicious user to perform a denial-of-service attack. PunBB 1.2.11 adds code to the registration script that prevents these flood registrations (an hour has to pass between registrations from the same IP). On top of this, an XSS vulnerability has been addressed.

For those of you not afraid to edit the scripts manually, here are the two changes:

http://dev.punbb.org/changeset/336
http://dev.punbb.org/changeset/335

Thanks to the people who alerted me via e-mail about the circulation of an "exploit" for the DoS attack.

how kan i installe it

PunBB, or the update?

Looking for a certain modification for your forum? Please take a look here before posting.

Re: PunBB 1.2.11

pogenwurst wrote:
grudon66 wrote:
Rickard wrote:

Here's a short message announcing 1.2.11. This release has been made primarily to address an issue with the registration script that allowed a malicious user to perform a denial-of-service attack. PunBB 1.2.11 adds code to the registration script that prevents these flood registrations (an hour has to pass between registrations from the same IP). On top of this, an XSS vulnerability has been addressed.

For those of you not afraid to edit the scripts manually, here are the two changes:

http://dev.punbb.org/changeset/336
http://dev.punbb.org/changeset/335

Thanks to the people who alerted me via e-mail about the circulation of an "exploit" for the DoS attack.

how kan i installe it

PunBB, or the update?

ok

PunBB, the FluxBB of tomorrow - today!

67 (edited by grudon66 2006-05-06 13:24)

Re: PunBB 1.2.11

grudon66 wrote:
pogenwurst wrote:
grudon66 wrote:

how kan i installe it

PunBB, or the update?

ok

but how kan ai update it

PunBB, the FluxBB of tomorrow - today!

Re: PunBB 1.2.11

grudon66 wrote:
grudon66 wrote:
pogenwurst wrote:

PunBB, or the update?

ok

but how kan ai update it

http://dev.punbb.org/changeset/336
http://dev.punbb.org/changeset/335

Modify the files referenced in those changesets.

Looking for a certain modification for your forum? Please take a look here before posting.

Re: PunBB 1.2.11

pogenwurst wrote:
grudon66 wrote:
grudon66 wrote:

ok

but how kan ai update it

http://dev.punbb.org/changeset/336
http://dev.punbb.org/changeset/335

Modify the files referenced in those changesets.

ok thanks

PunBB, the FluxBB of tomorrow - today!

70 (edited by mi 2006-08-14 09:57)

Re: PunBB 1.2.11

OOOPS - first time problem:
Upgrade manually from 1.2.10->1.2.11 gives this when trying to register:


Parse error: parse error in /Volumes/nn1/nn2/forum/register.php on line 82

What did i do wrong??

(Environment:
Operating system: Darwin
PHP: 4.3.10 - Show info
Accelerator: N/A

Database:
MySQL 4.0.18
Rows: 74717
Size: 3.64 MB

Apache webserver

Permissions etc correct...)

New Friendly web-shop! • SO happy with PunBB! • Now punBB 1.4.x on ALL forums (won't tell how many or their addresses to avoid spam-regs)

Re: PunBB 1.2.11

You probably just did a typo in register.php. Have you made any modifications to that file? If not, just upload a fresh copy.

"Programming is like sex: one mistake and you have to support it for the rest of your life."

72

Re: PunBB 1.2.11

Copied/pasted from diff html-page... o well, even copy/paste can fail, sometimes wink
Now, took "changed files"-archive, manually replaced files, works fine, even up to 1.2.12... but that's for a post in 1.2.12-thread...

THANKS again, for a FINE forum.

New Friendly web-shop! • SO happy with PunBB! • Now punBB 1.4.x on ALL forums (won't tell how many or their addresses to avoid spam-regs)