Topic: à isnt rendered as a with accent (`)

Hello, how can I solve this? it's only with a and the backleaning accent as used in france.

2 forums:

post form input: xàx

1 xàx  in the posts db, and renders it as: xàx
2 xà x in the posts db, and renders it as: x? x

all other accents/letter combinations are ok, even À.
php's mbstring.* seems not responsible for this? but what is? any help welcome.

Re: à isnt rendered as a with accent (`)

I don't really understand the issue. à is rendered find, whether it's a latin1 or 9 charset encoding, or a unicode encoding.

What are the forum incriminated?

Re: à isnt rendered as a with accent (`)

I'm not necesssarily incriminating the forum, just wonder if anyone encountered this before.

1 and 2 represent 2 different forums.

Re: à isnt rendered as a with accent (`)

Moved to Troubleshooting

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

Re: à isnt rendered as a with accent (`)

Well, maybe forum 2 has a charset that's doesn't accept à.

6

Re: à isnt rendered as a with accent (`)

When you post it, what language your are used in your profile?

If your people come crazy, you will not need to your mind any more.

Re: à isnt rendered as a with accent (`)

The default is on english, and in the per user profile there's no option for another language, as there is none on this forum we're talking on either.

Re: à isnt rendered as a with accent (`)

It's probably a php issue, hope it goes away when we upgrade sometime in the future.

Re: à isnt rendered as a with accent (`)

Check the whole character set chain.

What version of MySQL, what charset and collate are set in it, what charset is used by PHP to manipulate SQL data, what charset are sent by Apache and PHP, and what charset is set in the XHTML source code.

See if there is any inconsistencies, things like that.

10 (edited by pheldens 2007-02-05 09:45)

Re: à isnt rendered as a with accent (`)

Hi I solved it in the end by replacing iso-8859-1 with utf-8 in the english language file. I realise this may not be the root cause.

Re: à isnt rendered as a with accent (`)

pheldens wrote:

Hi I solved it in the end by replacing iso-8859-1 with utf-8 in the english language file. I realise this may not be the root cause.

I believe it is the root cause. Punbb needs to move to utf-8 asap.

Re: à isnt rendered as a with accent (`)

PunBB 1.3 has been planned with full Unicode support for some time now wink

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

Re: à isnt rendered as a with accent (`)

smile

Re: à isnt rendered as a with accent (`)

On this specific case, if it's a regular western latin à, iso-8859-1 handle it fine.

But anyway, utf8 is the way to go.