1 (edited by aaronbeekay 2006-12-10 19:40)

Topic: "PHP environment does not have support..." error during install

I'm running Apache 2 and PHP 5 on Ubuntu and trying to set up a punBB forum. Whatever I do, though, I get this message when I run install.php:

"This PHP environment does not have support for any of the databases that PunBB supports. PHP needs to have support for either MySQL, PostgreSQL or SQLite in order for PunBB to be installed."

I went so far as to uninstall and reinstall Apache and PHP, making sure that mysql.so was enabled in /etc/php5/apache2/php.ini. I know that my mySQL database is working OK-- I keep my music library in it.

Any ideas? Other Ubuntu/Debian/Linux users out there that can help me with any dumb configuration mistakes I might have made?

EDIT: Sorry, I forgot to post my phpinfo() page. It's http://www.cahsmic.com/testphp.php

Re: "PHP environment does not have support..." error during install

recompile apache w/ mysql support.

Re: "PHP environment does not have support..." error during install

Apache? hmm
I'm not sure what the problem is, your phpinfo() page has MySQLi in it hmm

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

4

Re: "PHP environment does not have support..." error during install

aaronbeekay wrote:

I went so far as to uninstall and reinstall Apache and PHP, making sure that mysql.so was enabled in /etc/php5/apache2/php.ini.

The extension would be mysqli.so, but Ubuntu should of done this for you.

I'm running Debian Etch:
Apache/2.2.3
PHP/5.2.0-7
MySQL/5.0.30

Damn it's good to see Debian on the leading edge wink

Re: "PHP environment does not have support..." error during install

It appears he got it going:

http://www.cahsmic.com/forum/index.php

"Programming is like sex: one mistake and you have to support it for the rest of your life."