Topic: Hdiffs

I was told here http://punbb.org/forums/viewtopic.php?id=15499&p=4 that there are hdiffs to update from any version of punbb to the latest... Why can't I find how to do from 1.2.13 to 1.2.15?

If you do what you've always done, you'll get what you've always gotten.

Re: Hdiffs

http://punbb.org/download/hdiff/hdiff-1 … .2.15.html

Re: Hdiffs

Awesome.
Thanks again.

If you do what you've always done, you'll get what you've always gotten.

Re: Hdiffs

I spent like 2 hours of fun with it smile

Now I wonder what is "db_update.php"...Do I need to run any file after I upload the updated files?

Besides, in header... Between 43 and 46 are the lines:

}
define('PUNRES_STYLE_COMPATIBLE', 1);
#

That aren't mentioned in the Hdiff... So I just deleted them ^^, I hope that this will be no trouble.

If you do what you've always done, you'll get what you've always gotten.

Re: Hdiffs

db_update.php is a 1.3 script, there's a different script in the extras folder for 1.2

And I've never heard of PUNRES_STYLE_COMPATIBLE before (actually, it looks to be something added by MyBestBB)

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

Re: Hdiffs

I have no idea where I got that piece of code from... I just deleted it anyways!

And oh thank you! I didn't get the 1.2.15 zip, so I didn't get to look at it.
I'll run my 1.2.15 peacefully (hopefully) now smile.

If you do what you've always done, you'll get what you've always gotten.

Re: Hdiffs

Hello again...

At the time -maybe because of that line in "header", the forum was shown as a blank page. So I knew something went wrong, and got back my files as backed up.
I then noticed that strangely, in the administration panel, my punbb version was shown as of 1.2.15, although it didn't work!
Now I got back to the hdiffs again, restarted everything from scratch, and kept that line of the header. When I tried to run the "12_to_1215_update.php" script, I got this error message:

File: xxxx/public_html/forum/12_to_1215_update.php
Line: 69

PunBB reported: Version mismatch. This script updates version 1.2, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.2.7, 1.2.8, 1.2.9, 1.2.10, 1.2.11, 1.2.12, 1.2.13, 1.2.14 to version 1.2.15. The database 'xxx' doesn't seem to be running a supported version.

I think that's due to the fact the I had 1.2.15 from my first attempt. Now at least the forum seems to be working properly. But I want to be sure that my 1.2.15 is up and kicking.

Any thoughts?

If you do what you've always done, you'll get what you've always gotten.