Topic: MySQL version poll

We're considering dropping support for MySQL 4.0 and older in PunBB 1.3. The reason we're considering this is that proper character set support was not added until 4.1. However, before we make any such decisions, we need to know what you guys think about it. Or rather, which version of MySQL you're using on your production server (web host, dedicated etc).

You can check your MySQL version by going to the admin interface start page and looking under "Database" at the bottom of the page. We would appreciate if you could just check your forums and copy/paste the version number in this topic.

Cheers,
Rickard

Edit: Please note that we're not particularly interested in which version you use for development smile

"Programming is like sex: one mistake and you have to support it for the rest of your life."

Re: MySQL version poll

MySQL client version: 5.0.22

MySQL client version: 4.1.22 (applies to more than one installation)

MySQL 4.1.9-max (via easyphp 1.8)

my mind is on a permanent tangent
byUsers forum

3

Re: MySQL version poll

Server version: 4.1.22-standard
MySQL client version: 4.1.21

Re: MySQL version poll

MySQL 4.1.22-standard

Ben

Re: MySQL version poll

MySQL 4.1.22-standard-log

mysql-5.1.22 (not production env ofc)

MySQL 5.0.45

Post hoc ergo propter hoc

Re: MySQL version poll

mysql  Ver 14.12 Distrib 5.0.22

5.0.24a-standard-log

7

Re: MySQL version poll

MySQL 5.0.41-community-nt

I'm using wos portable.

Re: MySQL version poll

MySQL 4.1.22
MySQL 4.1.20

Looking at the posts above me, it seems it'll be safe to drop 4.0 and lower smile

9

Re: MySQL version poll

MySQL 5.0.18

Re: MySQL version poll

MySQL 5.0.44

11 (edited by Utchin 2008-01-18 21:15)

Re: MySQL version poll

MySQL 5.0.22

(one of my hosts is using 4.1.22-standard but am going to MAKE them upgrade )

Sorry. Unactive due to personal life.

Re: MySQL version poll

MySQL 5.0.27-standard

13

Re: MySQL version poll

Mostly 5.0.xs - one or two 4.1.x versions (but specifically 4.1 rather than 4.0 to get the whole utf-8 stack right) - and one 3.x which we don't speak of. tongue

Re: MySQL version poll

All.. MySQL 5.0.27

Re: MySQL version poll

MySQL version    5.0.45-community

16 (edited by Jérémie 2008-01-19 01:10)

Re: MySQL version poll

Rickard wrote:

We're considering dropping support for MySQL 4.0 and older in PunBB 1.3. The reason we're considering this is that proper character set support was not added until 4.1.

MySQL < 4.1 can handle utf-8 for storage, even if it doesn't know what it is. However, since every host or server I use has at least a 4.1, personally, I don't care :-p

We would appreciate if you could just check your forums and copy/paste the version number in this topic.

- 5.0.32-Debian_7etch4-log Debian etch distribution
- 5.0.44-log

Hey, I found an old plan using 4.0.25-standard-log ! However, since migrating to 5.0.44 is a one-click step, doesn't matter smile

Edit: minor FYI, the #1 host in France provide 5.0.44 with every shared plan, and 4.1 or 5.0. branches for easy (like plesk or so) dedicated server.

17 (edited by quaker 2008-01-19 01:08)

Re: MySQL version poll

mine sql is

    MySQL 5.0.45

and my other site is

    MySQL 4.0.27

Q

My stuff or my style might sux, but atleast I'm willing to help when I can.
Don't be stupid and help ! We are the stupid one's !!!

Re: MySQL version poll

Jérémie wrote:
Rickard wrote:

We're considering dropping support for MySQL 4.0 and older in PunBB 1.3. The reason we're considering this is that proper character set support was not added until 4.1.

MySQL < 4.1 can handle utf-8 for storage, even if it doesn't know what it is. However, since every host or server I use has at least a 4.1, personally, I don't care :-p

Yeah, we've had this discussion before. However, it also means that things like search don't work properly for Russian characters, for example.

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

Re: MySQL version poll

quaker: Might I ask what hosting company is providing you with 4.0.27?

On a related note, I just went to mysql.com and they don't even provide links for 4.0 downloads in their download archive anymore.

"Programming is like sex: one mistake and you have to support it for the rest of your life."

Re: MySQL version poll

MySQL 4.1.22-standard

OnyxTalk.com - Peer to Peer Support & Discussion

21

Re: MySQL version poll

MySQL 5.0.51-community

22 (edited by pheldens 2008-01-20 11:37)

Re: MySQL version poll

5.0 here, your reasons sound good, utf8 is the futare (and should be the present!;))

Re: MySQL version poll

Based on the replies so far:

5.1: 3.6%
5.0: 60.7%
4.1: 32.1%
4.0: 3.6%

"Programming is like sex: one mistake and you have to support it for the rest of your life."

Re: MySQL version poll

My host is running MySQL 5.0.24.

Looking for a certain modification for your forum? Please take a look here before posting.

Re: MySQL version poll

4.0.27-standard

-Master Hob Bramble of Willowbottom

Pardon me, good sir, but it appears that your diving apparatus has a leak.
Perpetual Thursday | Alternative-Internet.com | hobbramble.deviantart.com