Topic: PunBB 1.4

We are delighted to announce that PunBB 1.4 has been released

List of changes from 1.3:

  • Support for international domain names (has to be turned on in the config)

  • Fixed censoring for Cyrillic and Unicode

  • Support for MySQL InnoDB and SQLite3

  • Faster sampling of messages in large topics

  • Numerous improvements and optimizations in Oxygen

  • Simplified Login, Registration, and Search forms

  • Automatic user time zone detection on registration

  • Minified javascript and style code for faster loading

  • Asynchrous javascript loading, based on LABjs

  • New profile fields: Facebook, Twitter, Skype, LinkedIn

  • Automatic redirection turned off by default

  • Dropped PHP 4 support. Minimum required PHP version is 5.0

  • Additional settings for turning on/off the list of moderators on the home page

  • Additional features for extension developers

  • Last visit time added to user profiles

  • Message sending on CTRL+Enter added

  • Subscription to topics added

(MD5 654ee353988f2c5328cc3c9600b0cb45)


  • Web server (preferably, Apache)

  • PHP 5.0 or newer

  • Database: MySQL 4.1.2 or newer, PostgreSQL 7.0 or newer, or SQLite 2 or 3


  1. Download the archive containing the latest version of PunBB, 1.4.

  2. Copy the archive contents to the forum folder on the web server (e.g. /home/user/example.com/punbb/).

  3. Open the main forum page in your browser and follow the instructions.

Upgrade from 1.3
NOTE: Make a backup of your current forum folder before proceeding. Also, don't forget to make a backup of your forum database. Use mysqldump for MySQL and pg_dump if you are using PostgreSQL. If you're using SQLite, just make a backup copy of the SQLite database file. You can also make database backups via most administration tools, such as MySQL Administrator, phpMyAdmin and phpPgAdmin.

  1. Turn the Maintenance mode on via the admin panel.

  2. Disable all extensions via the admin panel.

  3. Overwrite the old files with the new ones.

  4. After owerwriting, verify that the cache, img/avatars and extensions (for pun_repository) directories are set enough write permissions (usually 777 or 755).

  5. Clear the cache directory.

  6. Go to the forum index and run the db_update.php script (this may take a while to finish).

  7. Update all the extentsions.

  8. Turn on all the updated extensions.

  9. Turn the Maintenance mode off.

List of extensions compatible with PunBB 1.4
Please avoid using extensions written for PunBB 1.3. Such older extensions may cause problems with your website's speed, security, and stability. At the moment, we are rather limited in terms of resources, so we have only updated and are now supporting the most important and popular extensions.

Known issues

  • The info about the latest registered user is updated once every 30 minutes.

  • We have reports about broken upgrades with SimpleScripts - do not use this method for upgrade.


  • Switch off or remove the pun_repository extension: it hasn't been updated for PunBB 1.4

  • To fight off spam, turn on registration confirmation by e-mail in your forum settings and set up the Fancy Stop Spam extension

  • After installation, switch off (set to 0) the redirection timeout

  • We haven't tested this forum version on Microsoft Windows servers ourselves, but we had reports about it working nicely on that platform


We are grateful to all those who helped us test the new version and sent us bug reports.

Re: PunBB 1.4

Excellent work. Needs a few themes added .. http://punbb.informer.com/forums/topic/ … -template/

Re: PunBB 1.4

Will add forums for Punbb1.4?

Taiwan is a country.
I am sorry for my English.


Re: PunBB 1.4

Of course

Re: PunBB 1.4

Is there a good writeup of the changes extension developers need to take in to account for 1.4? I've been really busy lately but I want to at least update my released extensions to be 1.4 compatible.

So far I am aware of:

  • $forum_db->num_rows() being deprecated

  • use $forum_loader for CSS + JS

If that's it, I'll probably get around to updating my extensions ASAP.

Re: PunBB 1.4

We have reports about broken upgrades with SimpleScripts - do not use this method for upgrade.

7 (edited by qie 2011-11-10 02:27)

Re: PunBB 1.4

does that punbb.informer.com/forums using punbb1.4 now?

Re: PunBB 1.4

Yes, we updated to 1.4

Re: PunBB 1.4

Fast way to check outdated extensions

If you have text like on image at left (Currently installed 4 official extensions.) - you are have installed a few extensions from old 1.3 version. Extensions in PunBB 1.4 don't add this text to footer. Check and update this extensions.

Re: PunBB 1.4

For one forum I haven't updated punbb for a very long time. Should an update from 1.2 directly to 1.4 work?

Re: PunBB 1.4

We dont test this. Make backup files and databases before updating.

12 (edited by felixturner 2011-11-18 07:45)

Re: PunBB 1.4


I suggest you modify the upgrade instructions to make them slightly less ambiguous for non punbb experts:

"3: Overwrite the old files with the new ones." Does this mean a windows-style - replace only newer files, or a mac-style - trash entire folder and replace with new files? I'm guessing it means overwrite only newer files.

"5: Clear the cache directory." - does this mean delete everything in /forum/cache?

"7: Update all the extentsions." - How?

Most importantly - Move this "Switch off or remove the pun_repository extension: it hasn't been updated for PunBB 1.4" from 'Recommendations' to step 2, since enabling it breaks the forum and requires a restore back to v1.3.


13 (edited by felixturner 2011-11-18 07:59)

Re: PunBB 1.4

Registration Captcha is broken in v1.4. Antispam System Version 1.3.4 Official plugin should work out of the box no?

After 3 hours trying to upgrade about to revert back to v1.3.

Re: PunBB 1.4

A you reading instructions in first post?
List of supported extensions - http://punbb.informer.com/forums/topic/ … dy-for-14/


Re: PunBB 1.4

In 1.3 I took the oxygen template and made a site specific template. What changes have been done with the new 1.4 oxygen template vs the 1.3 template. Are there some of these that I really should update to, and some that are optional?!

Re: PunBB 1.4

Use this https://gist.github.com/1383386