101

Re: PunPoll v1.2.3

SpAZ wrote:
Chacmool wrote:

Any suggestions or comments?

Yeah, DONT SHOW PPL THAT HAVENT VOTED! lol, lets say u have like 2k members. that wouyld be annoyting and also display who voted for what ;)

Hehe, true :) I'll probably look at it later this week (as everything else http://punbb.org/forums/img/smilies/roll.png)

pl0x wrote:

As I understand people from one IP can vote only once(not each of them). There is no difference if they are from different computers or not. Am I right ?

The user-id is saved in the database, so users can only vote one time, and it's not tied to any specific IP.

102

Re: PunPoll v1.2.3

if you show who voted maybe let people choose if its shown, sometimes polls are private (as in people don't want you to know what they voted)

103

Re: PunPoll v1.2.3

It's only showed in the admin-section...

104

Re: PunPoll v1.2.3

oh
/me should read previous posts wink

105

Re: PunPoll v1.2.3

Yet another good mod from Chacmool. wink

106

Re: PunPoll v1.2.3

works like a charm m8!! THX a lot! big_smile:D:D:D:D:D

107

Re: PunPoll v1.2.3

Does it work with Punbb 1.2?

108

Re: PunPoll v1.2.3

probably not, well not properly anyway

Re: PunPoll v1.2.3

get working on this for 1.2, as well as Private messages for 1.2.

lol tongue i cant use 1.2 until these are made, thats all. tongue (ohh ya the phpbb conversion tool aswell big_smile)

110

Re: PunPoll v1.2.3

he did the convertor already

Chacmool wrote:

I've now updated the converter so it can handle PunBB 1.2.

Download the beta here.

111

Re: PunPoll v1.2.3

beta's suck, we want a stable release tongue

-gezz

Re: PunPoll v1.2.3

SpAZ wrote:

Yeah, DONT SHOW PPL THAT HAVENT VOTED! lol, lets say u have like 2k members. that wouyld be annoyting and also display who voted for what wink

yeah, this is the first thing I have to disable smile

[no signature]

113

Re: PunPoll v1.2.3

I ported punpoll for my punbb 1.2 forum and It's working smile. Here is the mod.

114 (edited by Azakur4 2005-02-05 07:09)

Re: PunPoll v1.2.3

nice work demon, the mod work well for me but i need to do some changes. in the readme of your mod you put $pun_root but now is only PUN_ROOT, you sure forggot of to do the changes.

i found a bug, the guest can vote and i want to ask a question, what is the funtion of the .post_form.php.swp file?

other bug, i tryed to fix the problem but i can't

attached is the image

http://img207.exs.cx/img207/9593/bug8sh.jpg

well i solved the bug thanks.

El Mejor Lugar de la Red - Corporación Azakur4

115 (edited by filt 2005-02-06 18:44)

Re: PunPoll v1.2.3

When i go to post.php i get the following errors:

Notice: Undefined index: o_polls in /home/filt/bajskorv.se/post.php on line 515
Notice: Undefined index: o_polls in /home/filt/bajskorv.se/include/punpoll/post_form.php on line 5
Notice: Undefined variable: cur_user in /home/filt/bajskorv.se/include/punpoll/post_form.php on line 5

And when i click "Post a new poll" i dont get the poll up.

When i go to the admin pages and click "Polls" i get

Warning: Division by zero in /home/filt/bajskorv.se/admin_polls.php on line 175

but i guess thats becouse i dont have any polls...

When i go to Admin pages and click "Permissions" i get the following errors:

Notice: Undefined variable: pun_root in /home/filt/bajskorv.se/admin_permissions.php on line 171
Notice: Undefined index: p_guests_poll in /home/filt/bajskorv.se/include/punpoll/admin_permissions.php on line 9
Notice: Undefined index: p_guests_poll in /home/filt/bajskorv.se/include/punpoll/admin_permissions.php on line 9

Any idea why?

116

Re: PunPoll v1.2.3

umm the problem with the "Notice: Undefined index: o_polls" is because you don't run the install_mod.php

and the "Warning: Division by zero"

the problem is because you do not have any poll in your forum.

El Mejor Lugar de la Red - Corporación Azakur4

117

Re: PunPoll v1.2.3

Azakur4 wrote:

umm the problem with the "Notice: Undefined index: o_polls" is because you don't run the install_mod.php

and the "Warning: Division by zero"

the problem is because you do not have any poll in your forum.

I did run install_mod.php

And i got a message saying everything went well...

118

Re: PunPoll v1.2.3

hi men add me your msn mi mail is captasfire@hotmail.com and can help you

El Mejor Lugar de la Red - Corporación Azakur4

119

Re: PunPoll v1.2.3

Problem solved. Thanks alot Azakur4

120

Re: PunPoll v1.2.3

Just realized i have one more error. When i post, i get this:

Notice: Undefined variable: poster in /home/filt/bajskorv.se/include/punpoll/viewtopic.php on line 48

Notice: Undefined variable: poster in /home/filt/bajskorv.se/include/punpoll/viewtopic.php on line 48

Notice: Undefined variable: poster in /home/filt/bajskorv.se/include/punpoll/viewtopic.php on line 48

Notice: Undefined variable: poster in /home/filt/bajskorv.se/include/punpoll/viewtopic.php on line 48

Notice: Undefined variable: poster in /home/filt/bajskorv.se/include/punpoll/viewtopic.php on line 48

Re: PunPoll v1.2.3

I get this error in admin_options.php
Notice: Undefined variable: pun_root in /home/ravingat/public_html/forum/admin_options.php on line 404

122

Re: PunPoll v1.2.3

change $pun_root on that line to PUN_ROOT (it's no longer a variable, it's now a constant)

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

123 (edited by boneheade 2005-02-08 00:56)

Re: PunPoll v1.2.3

Thanks for your reply. I've found $pun_root in other places and replaced it. I'm not getting any errors but I can't save a post with a poll. I did however see some warnings in my error log:

[error] PHP Notice:  Undefined variable:  poster in /home/username/public_html/forum/include/punpoll/viewtopic.php on line 48
[error] PHP Notice:  Undefined index:  type in /home/username/public_html/forum/include/punpoll/post_save.php on line 27

124

Re: PunPoll v1.2.3

this problem, i think that is for the version of the server mysql.

my server work with mysql 4.0.23 and punpoll work fine but in mysql 4.1 i see some problems

El Mejor Lugar de la Red - Corporación Azakur4

Re: PunPoll v1.2.3

It works fine now. The errors were my fault. I had punpoll installed before and had to delete the table, then run the install again.