Topic: PunBB 1.2.5

I am glad to announce the release of PunBB 1.2.5. This release incorporates a number of security upgrades, a few bug fixes and a rather large performance tweak (primarily affecting very busy forums). Due to the critical nature of one of the vulnerabilities, PunBB 1.2.5 is a recommended upgrade for everyone. Once again, I'm sorry for the high frequency of updates. At least no one can blame PunBB for being a dead project :)

This time I would like to extend my thanks to Stefan Esser for reporting the critical vulnerability and giving me time to put out this release. A huge thanks also goes out to forum regular Smartys for reporting the XSS vulnerability. Thank you both very much.

IMPORTANT: Two rather annoying bugs have surfaced since the release of 1.2.5. See this post for instructions on how to fix them.

"Programming is like sex: one mistake and you have to support it for the rest of your life."

Re: PunBB 1.2.5

Oooh, a new version smile

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

3 (edited by shinko_metsuo 2005-04-08 01:42)

Re: PunBB 1.2.5

I was expecting the newest version to come out ot be 1.3.0 but hey anything better than what I have is great.

4 (edited by rootuid 2005-04-08 00:48)

Re: PunBB 1.2.5

And I only installed the latest 1.2.4 12 hours prior smile Great work however I am having some problems with posts by guests repeating. I've run the maintenance script. The post count is correct but the post appears multiple times.It doesn't happen to members. Any ideas ?

http://www.wonkasworld.com/forum/viewtopic.php?id=4

5

Re: PunBB 1.2.5

rootuid wrote:

And I only installed the latest 1.2.4 12 hours prior smile Great work however I am having some problems with posts by guests repeating. I've run the maintenance script. The post count is correct but the post appears multiple times.It doesn't happen to members. Any ideas ?

http://www.wonkasworld.com/forum/viewtopic.php?id=4

Its not just you so sit tight.

Re: PunBB 1.2.5

this was my first update using the patch and it worked great, cept for the install.php file wink and the profile.php and viewtopic.php witch have been modded. but other than that worked like a charm. big_smile

Re: PunBB 1.2.5

*sits tight on 1.2.4 install until the word is given*

neutral

8 (edited by Endre 2005-04-08 10:58)

Re: PunBB 1.2.5

I've made the change now, and the forum is notably faster.. I don't understand how u people do it. It could be a coincidence, cause my server has its good days and bad, but the forum definitely responds faster now.


I'm updating manually with the hdiff. Is it enough to change the files and run the Version Changer plugin? I'm wondering if I need to run the update-script. It seems to work fine without runnnig the script..

Re: PunBB 1.2.5

Seems to work fine.

One thing (it was my forst PunBB update) : why the .patch doesn't have to update script ? It's kinda strange to have to get it from the main archive, put it where it belong and run it.

Re: PunBB 1.2.5

After updating manually using hdiff from 1.2.4, I got trouble while logout(load index.php) after singing in as Admin. I got message said that can't write cache config blah..blah.., I forgot about it.

I fix it by deleting all the cache then replace parser.php with the old one(before updating). Don't know why this happen, after all it works great...

Re: PunBB 1.2.5

I've done 1.3 to 1.25 and it's ok.
Thanks Rickard.

Sorry for my french english.
GT4 Club driver France & Forum - Lingerie.

Re: PunBB 1.2.5

Endre wrote:

I'm updating manually with the hdiff. Is it enough to change the files and run the Version Changer plugin? I'm wondering if I need to run the update-script. It seems to work fine without runnnig the script..

You don't need to run the upgrade script if you just upgraded from 1.2.1, 1.2.2, 1.2.3 or 1.2.4.

"Programming is like sex: one mistake and you have to support it for the rest of your life."

13

Re: PunBB 1.2.5

Hello guys!

I just uploaded all relevant files of the 1.2.5 release, but PunBB still shows " PunBB 1.2.4".

What could be happening, please?

-a

Re: PunBB 1.2.5

avorio: Did you read the upgrade instructions in http://punbb.org/docs/install.html ?

"Programming is like sex: one mistake and you have to support it for the rest of your life."

Re: PunBB 1.2.5

Two bugs have surfaced since the release of 1.2.5. To fix these bugs, apply the following changes:

http://dev.punbb.org/changeset/172
http://dev.punbb.org/changeset/173

I might release a revised version or fix up some other things I have piled up and release 1.2.6. We'll see. For now, I suggest you apply these changes.

"Programming is like sex: one mistake and you have to support it for the rest of your life."

Re: PunBB 1.2.5

I did it. It's more a 1.2.51 than a 1.2.6 no ?

Sorry for my french english.
GT4 Club driver France & Forum - Lingerie.

Re: PunBB 1.2.5

1.2.51 indicates version 51 not 5.1

Re: PunBB 1.2.5

1.2.5b wink

I enjoy pie :)

Re: PunBB 1.2.5

Thanks but I can't use a patch due to shell restrictions. Is it possible to download these two modified files.

Re: PunBB 1.2.5

just do the modifications manually? open the files and do the 2 edits

21

Re: PunBB 1.2.5

Thanks again for a great release.  Even though the releases are frequent... I would rather have the updated versions with security problems addressed than have a version with problems.  Keep up the excellent work, Rickard!  It is very much appreciated!

If its cheaper to run Windows than it is to run Linux, how come Microsoft has all the money?

Re: PunBB 1.2.5

If I can get a few hours off tomorrow night, I might just fix a few other things and release a new version. We'll see.

"Programming is like sex: one mistake and you have to support it for the rest of your life."

23

Re: PunBB 1.2.5

how do i update with my forums without my mods getting screwed up???  cause all my mods usually get screwed up when i update

24

Re: PunBB 1.2.5

cows wrote:

how do i update with my forums without my mods getting screwed up???  cause all my mods usually get screwed up when i update

its a trial and error i have the same problem here

Re: PunBB 1.2.5

you can either apply the patch file http://punbb.org/download/patch/instructions.txt which might or might not work fully

or manually do the edits http://punbb.org/download/hdiff/hdiff-1 … 1.2.5.html