426

Re: Attachment Mod 2.0.1 by Frank H

With FileZilla.
Which is the text of the .htaccess?

I still don't know why when installing the mod it creates random folders on my host...

Thanks!

427

Re: Attachment Mod 2.0.1 by Frank H

Oh, that's part of the mod. It does that randomly. Wait a second, it might be faster to chat...
I have a chat room in my forum, so just follow this link:
http://www.bydebrasdesigns.com/biblestu … m/chat.php
I just have to allow guests to chat. So just wait one minute, and then join, please!!!

FluxBB - v1.4.8

428

Re: Attachment Mod 2.0.1 by Frank H

Hi,

After using the excellent mod successfully a while, I tend towards wanting to display the filesize in KB and MB rather than bits. Is that possible to change?

I sincerely hope you will make an extension of this for 1.3 - I really can't wait to update! smile'

Thanks for a brilliant mod.

Jan Terje

429

Re: Attachment Mod 2.0.1 by Frank H

I am having a strange problem with this mod. I am using the latest version of punBB. Here is the problem. I attach a file either using "post" or "new thread" but the file does not get posted. However, if I edit the post and then attach the file, it then displays on the thread. Any idea why this is happening? I've reinstalled this mod 3 times so far and get the same results.

Thanks
Bingiman

430

Re: Attachment Mod 2.0.1 by Frank H

janterje wrote:

I tend towards wanting to display the filesize in KB and MB rather than bits. Is that possible to change?

Not out of the box, you need to modify the output, replacing the bytes and lang string with your own stuff.


bingiman wrote:

I am having a strange problem with this mod. I am using the latest version of punBB. Here is the problem. I attach a file either using "post" or "new thread" but the file does not get posted. However, if I edit the post and then attach the file, it then displays on the thread. Any idea why this is happening? I've reinstalled this mod 3 times so far and get the same results.

If you zip the changed files (and mail them to the email found in the readme.txt), I'll have a look to see if I can spot something in them.

431

Re: Attachment Mod 2.0.1 by Frank H

Thanks Frank,

I've sent the files via email to you.

Cheers!
Bingiman

432

Re: Attachment Mod 2.0.1 by Frank H

I also noticed something today. How come I don't see the saved info in the "Alter Settings" area. I add the paths to the icons etc and the path to save files and it always shows up blank and icons aren't displayed next to the attachments. I also noticed that my files are being saved in my C drive root folder. (It is my local site and not a production site just yet) and it doesn't matter what I use as the path.

433

Re: Attachment Mod 2.0.1 by Frank H

What server are you running?

434

Re: Attachment Mod 2.0.1 by Frank H

I am just using Windows XP Pro on my PC

435 (edited by chopiesel 2007-03-19 02:07)

Re: Attachment Mod 2.0.1 by Frank H

i have it installed on 1.2.14

the install went fine but when anyone tries to post with or without a file attached they get an error that says

    *  Usernames must be at least 2 characters long. Please choose another (longer) username.
    * The e-mail address you entered is invalid.


iv searched for hrs but no luck

436

Re: Attachment Mod 2.0.1 by Frank H

Make sure all the modifications in post.php are made correctly. Sounds like the guest posting is triggered ...

Did you follow the installation guide I mentioned in the first post of this thread? (also the parts about testing the mod, and setup the mod)

437 (edited by andreizill 2007-04-03 02:07)

Re: Attachment Mod 2.0.1 by Frank H

Such statements are totally unnecessary; if you're having trouble with this mod then please address your issues in a constructive manner. /pogenwurst

Sorry, but it just seems like an 11 year old wrote the thing.

438

Re: Attachment Mod 2.0.1 by Frank H

I'm trying to install this mod but in the readme file it says to copy install.htm (not .html) in the attachments directory I created. But ... there is not index.htm in the files contained in the zip. So ... where do I get this file? Or do I create it myself?

439

Re: Attachment Mod 2.0.1 by Frank H

Just create a blank file, call it index.html

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

440

Re: Attachment Mod 2.0.1 by Frank H

hmm ... it should say index.html  ... (it's just an "empty" file, to stop directory listings)

odd that noone have noticed that until now big_smile  Thanks smile

441

Re: Attachment Mod 2.0.1 by Frank H

hehe no problem Frank! wink  So ... it's index.html then? Ok ... I'll create that blank file!

Thanks guys! smile

442

Re: Attachment Mod 2.0.1 by Frank H

OK ... I ran the install_mod.php and it says that it doesn't work with the latest version of punBB!?? What do I do now?

443

Re: Attachment Mod 2.0.1 by Frank H

Open the install_mod.php file, somewhere on the top (in the code) there is a version array. Just add your version, upload, and run again...

FluxBB - v1.4.8

444

Re: Attachment Mod 2.0.1 by Frank H

thank you thank you thank you!!!

445

Re: Attachment Mod 2.0.1 by Frank H

OK ... I tried installing this again and I now get this error message:

An error was encountered
File: /domain/forums/install_mod.php
Line: 114

PunBB reported: Unable to create new subfolder with name '/domain/forums/attachments/48b28b987ce00d7c0a70d7d70dcfb535' with mode 0750

Any ideas?

446

Re: Attachment Mod 2.0.1 by Frank H

chmod your forums folder to allow the script to write in it

447 (edited by karinne 2007-04-27 22:28)

Re: Attachment Mod 2.0.1 by Frank H

Ok ... all along it was because I didn't put the right folder name in the filed before clicking "Install"

But ... now I did and I get this message:

File: /domain/forums/install_mod.php
Line: 117

PunBB reported: Unable to copy .htaccess file to new subfolder with name '/domain/forums/files/24d932528896ab955112e3484c661692'

And I did copy the .htaccess file from the zip to that folder.

Any ideas?

Thanks!

448 (edited by Rustin 2007-04-24 00:44)

Re: Attachment Mod 2.0.1 by Frank H

karinne - It looks like the mod just needs the permissions to be set correctly on the folder at

'/home/web/ca/widowswalk/www/forums/files/24d932528896ab955112e3484c661692'

It's got to be able to write to that directory.

Just chmod that folder to something open like 777 and try it out.  If it works then you know that was the problem.

(you'll want to chmod that directory back to a resonable level once you get it all working)

449 (edited by karinne 2007-04-24 23:22)

Re: Attachment Mod 2.0.1 by Frank H

But ... that's a folder created by the script. I created the files folder and gave it the proper permissions (777).

450

Re: Attachment Mod 2.0.1 by Frank H

So the script was able to create the folder but not write to it?  That seems strange.  See if you can find out what the current security is on the folder...  or delete it completely and have the script make a new folder.