176

Re: Private Message mod v1.2.2

when i run the install i get this error anyone know why?



An error was encountered
File: /home/natmil/forum/install_mod.php
Line: 62

PunBB reported: Unable to create table messages.

Database reported: Invalid default value for 'owner' (Errno: 1067)

177

Re: Private Message mod v1.2.2

looks like you don't have permission to write.

178 (edited by skilz 2006-11-13 04:04)

Re: Private Message mod v1.2.2

i set all file permissions to 777 and it still wont work. think you could help me install it. im kinda new to this stuff.

179

Re: Private Message mod v1.2.2

have you ever installed it before or are you upgrading?

make sure you read the instructions carefully.

180

Re: Private Message mod v1.2.2

nope i have never installed this before. and i have placed each file in the correct folder. but yet i still get the same error.

181 (edited by scneko 2006-11-20 01:29)

Re: Private Message mod v1.2.2

Im also geting this error that skilz is geting, im using punBB 1.2.14

PHP is able to write to the files. And this is not a upgrade either but a new install of this mod.

182

Re: Private Message mod v1.2.2

OK guys, this error has NOTHING to do with write permissions. It's a known bug with the install_mod.php for this mod.
You'll have to go through and change every place where it says DEFAULT '0' to say DEFAULT 0

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

183

Re: Private Message mod v1.2.2

Thanks Smartys I changed every DEFAULT '0' to DEFAULT 0 and im still geting that error, my guess is maybe this mod is having issues with mysql 5? which is what I run off of

Re: Private Message mod v1.2.2

remove all DEFAULT '' at line 50, 51, 53, 54, 55

185

Re: Private Message mod v1.2.2

thanks duomaxwellr! that did the trick

186 (edited by vildsint 2006-11-23 00:46)

Re: Private Message mod v1.2.2

I need some help.


I resently upgraded from 1.2.7 to 1.2.14 and added some other mods while doing that.

Now I users dont get a notification that they have new PM's.

Before there was a message up by login name that said something like "you have a new PM"

The message mod seem to work as it should beside that I dont get the alertments of new PM's.

Help.

------------------------------------------------------------------------------------------------------------

I tracked down the problem

require(PUN_ROOT.'include/pms/header_new_messages.php');

Was missing from header.php.

Some way it got erased when I installed new addons.

187 (edited by yi3artist 2006-12-11 14:18)

Re: Private Message mod v1.2.2

I've translated the /lang/pms.php to Chinese (simplified). I'm not native, but am studying overseas and confirming lines with natives. I will be having a native (whose English rocks and who is a programmer) to look over it when she has time. I'll come back with an updated version if changes are made.

The Chinese wouldn't show up in the preview of this post, so I've posted it on my site:
http://twalrpg.net/teralis/viewtopic.php?pid=985#p985

188

Re: Private Message mod v1.2.2

I have read the whole topic, but only found one guy posting about the same as I'm going to do.

There is no submit button when you try to delete multiple messages. I followed the readme 100%. I even tried a clean install, but it' s not there.
Anyone else got this problem/bug?

189

Re: Private Message mod v1.2.2

Would anyone know what would be in the contents of the message_popup.php file that is shown as an example here:
http://punbb.org/forums/viewtopic.php?pid=70364#p70364

I am trying to show a popup when a new PM has been received.

Thanks
Bingiman

Re: Private Message mod v1.2.2

strongholdkennel wrote:

I followed directions now my site is a blank white page

any suggestions

I had the same problem, and it turned out to be the language pack that caused it. Try moving the english pms.php into your language folder and see if it helps.

191

Re: Private Message mod v1.2.2

i installed this mod and now i can't log out of my forum using punbb 1.2.17

192 (edited by PhaxeNor 2008-04-04 21:48)

Re: Private Message mod v1.2.2

jay576 wrote:

i installed this mod and now i can't log out of my forum using punbb 1.2.17

Recheck your stuff.

This works fine on my forum. And its 1.2.17 aswell

193

Re: Private Message mod v1.2.2

That's because the readme of this mod asks to replace a piece of code in which you have the logout links at step 11. As the logout link has been change in 1.2.17 and this mod was written before, it makes you replace the logout part with a no longer valid code.
You just have to replace login.php?action=out&id='.$pun_user['id'].'
by login.php?action=out&id='.$pun_user['id'].'&csrf_token='.pun_hash($pun_user['id'].pun_hash(get_remote_address())).'

194

Re: Private Message mod v1.2.2

thanks works now

195

Re: Private Message mod v1.2.2

Heya!

I've one question about this PM system. I use it on my current forum and it works great, no really trouble with it.. but

Is there any chance of getting a notification if you have a new message, like change the color of the text - message or something like that.

Would help a lot, thanks.

-Tox

196

Re: Private Message mod v1.2.2

I'm using v1.2.3 of this mod on a Punbb 1.2.17 install. Everything has worked smoothly up to this point, but starting yesterday, when I try to click on the Messages link, Firefox 2.0.0.14 is being prompted to download message_list.php rather than display it. It works fine in IE6, but FF wants to download the file.

I've checked error logs, etc. and can't find anything. The rest of the forum works fine - I don't get the download message anywhere else.

Any ideas on what might be causing this? It's strange that it just started happening.

197

Re: Private Message mod v1.2.2

I'm currently running Apache (httpd) on Archlinux. I tried to install this plugin, and everthing works great. But when I go to administration and click on "Privacy messaging" to adjust options, I get a white page. Which is very wierd. I never experienced this on Ubuntu.

198

Re: Private Message mod v1.2.2

compengi wrote:

I'm currently running Apache (httpd) on Archlinux. I tried to install this plugin, and everthing works great. But when I go to administration and click on "Privacy messaging" to adjust options, I get a white page. Which is very wierd. I never experienced this on Ubuntu.

Try to look at your Apache's error.log for PHP or httpd errors.
Any other symptoms? :-)

Carpe diem

199

Re: Private Message mod v1.2.2

My problem is fixed now. Many thanks to MattF. I'm just commenting here for other people that could have some similar issues and following up with this post.

MattF wrote:

Edit: One thing I would suggest checking with the plugin is for php short tags, i.e: <? instead of <?php. You may not have those enabled on the server, and I seem to recall the mod was a sod for those everywhere, unless they were changed in the last update.

It was short_open_tag set to Off by default which is responsible for "<?" support. And it's the single short tag in the plugin. Now my issue is fixed and the plugin configure section works fine.

Original post is here.

200

Re: Private Message mod v1.2.2

Hello,

I have and error with this mod, installation success, but then i login i cannot logout, any ideas ?