1 (edited by pogenwurst 2006-02-15 20:02)

Topic: [HOWTO] - Upgrade mod compatibility for 1.2.*

Lots of people have been asking for mods to be "upgraded" to work on the current version of PunBB. However in most cases there is not really a need to ask for this. All you need to do is:

1. Open install_mod.php
2. Find line 12
3. Add the version of the forum you are using to the version array
4. Save and upload

That's it.

Your version array should then look something like this...

$punbb_versions    = array('1.2.8', '1.2.9', '1.2.10');

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

Great. I think this was needed smile

"Programming is like sex: one mistake and you have to support it for the rest of your life."

3 (edited by Mark 2006-02-15 21:57)

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

ive seen lots of people asking how to do it, so i thought i would post how to wink

and what needed neatening up on it could i ask?

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

Mark wrote:

Lots of people have been asking for mods to be "upgraded" to work on the current version of PunBB. However in most cases there is not really a need to ask for this. All you need to do is:

1. Open install_mod.php
2. Find line 12
3. Add the version of the forum you are using to the version array
4. Save and upload

That's it.

Your version array should then look something like this...

$punbb_versions    = array('1.2.8', '1.2.9', '1.2.10');

I have a forum on lx.ro and r2.ro ... it is more easy to use ftp ... but r2 do not allow that.. can you give me a link or tell how i upgrade my forum on r2.ro? I must make a back up ? can i upgrade without made this and don`t lost the data?

5

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

your wanting to upgrade your punbb forum?
from what version?

this thread is for making mods working on a different version of punbb, not upgrading your forum version.

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

Mark wrote:

your wanting to upgrade your punbb forum?
from what version?

this thread is for making mods working on a different version of punbb, not upgrading your forum version.

My bad then sad.  From version 1.2.5  to  1.2.11. Where can i read about that ? ( i look over this forum for about 1 hour and i don`t find anything big_smile )

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

lpionutz wrote:

My bad then sad.  From version 1.2.5  to  1.2.11. Where can i read about that ? ( i look over this forum for about 1 hour and i don`t find anything big_smile )

Hopefully this will help you.

Mark wrote:

and what needed neatening up on it could i ask?

I just corrected a few tiny grammar, punctuation, and capitalization errors (if my memory serves me correctly).

Looking for a certain modification for your forum? Please take a look here before posting.

8

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

pogenwurst wrote:
Mark wrote:

and what needed neatening up on it could i ask?

I just corrected a few tiny grammar, punctuation, and capitalization errors (if my memory serves me correctly).

ahhh ok, no worrys tongue

9 (edited by pogenwurst 2006-03-15 22:54)

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

Mark wrote:
pogenwurst wrote:
Mark wrote:

and what needed neatening up on it could i ask?

I just corrected a few tiny grammar, punctuation, and capitalization errors (if my memory serves me correctly).

ahhh ok, no worrys tongue

Worries wink

Sorry to be a jerk, I just couldn't resist

Looking for a certain modification for your forum? Please take a look here before posting.

10

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

I'm running the latest version of pun (1.2.12) - but the following mod (http://punbb.org/forums/viewtopic.php?id=6101&p=1) states it wont work on my version of pun.

Will the instructions given by Mark help to solve this?

11 (edited by nick23 2006-07-09 03:01)

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

edit...

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

nick23 wrote:

I'm running the latest version of pun (1.2.12) - but the following mod (http://punbb.org/forums/viewtopic.php?id=6101&p=1) states it wont work on my version of pun.

Will the instructions given by Mark help to solve this?

If install_mod.php gives you an error about not having the correct version of PunBB, then yes, this guide will solve that problem.

Looking for a certain modification for your forum? Please take a look here before posting.

13 (edited by PSPpimp 2006-12-13 17:35)

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

Thank you man i need this bad smile

ok i edit the 12 line

from

$punbb_versions    = array('1.2.3', '1.2.4', '1.2.5', '1.2.6');

to

$punbb_versions    = array('1.2.3', '1.2.4', '1.2.5', '1.2.6', '1.2.7', '1.2.8, '1.2.9, '1.2.10, '1.2.11, '1.2.12, '1.2.13, '1.2.14,);

is that rigth as i have the new forum 1.2.14 ?? or did i do it wrong


when i go to install it i get this

http://www.psp-personalize.net/forum/install_mod.php

this the link it dead it say's

Parse error: syntax error, unexpected T_DNUMBER, expecting ')' in /hermes/web03/b49/pow.freakazo/htdocs/forum/install_mod.php on line 12

and the reset of the website is white


--------------------------------------------------------------------------------------------

with the rep mod when you edit the install_mod.pbp it look's like this

<?php
/***********************************************************************/

// Some info about your mod.
$mod_title      = 'Reputation System';
$mod_version    = '2.2.0';
$release_date   = '06-04-24';
$author         = 'hcs';
$author_email   = 'hcs@mail.ru';

///Mysql error
///Error: 1062 SQLSTATE: 23000 (ER_DUP_ENTRY)
///Message: Duplicate entry '%s' for key %d

///Error: 1054 SQLSTATE: 42S22 (ER_BAD_FIELD_ERROR)
///Message: Unknown column '%s' in '%s'

///Error: 1146 SQLSTATE: 42S02 (ER_NO_SUCH_TABLE)
///Message: Table '%s.%s' doesn't exist

///Error: 1060 SQLSTATE: 42S21 (ER_DUP_FIELDNAME)
///Message: Duplicate column name '%s'

///Error: 1050 SQLSTATE: 42S01 (ER_TABLE_EXISTS_ERROR)
///Message: Table '%s' already exists

///Error: 1061 SQLSTATE: 42000 (ER_DUP_KEYNAME)
///Message: Duplicate key name '%s'

// One or more versions of PunBB that this mod works on. The version names must match exactly!
$punbb_versions    = array('1.2.10', '1.2.11');

$punbb_versions    = array('1.2.10', '1.2.11');   is one line 31 ???

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

$punbb_versions    = array('1.2.3', '1.2.4', '1.2.5', '1.2.6', '1.2.7', '1.2.8', '1.2.9', '1.2.10', '1.2.11', '1.2.12', '1.2.13', '1.2.14');

15 (edited by Dr.Jeckyl 2006-12-13 17:59)

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

if i recall you only have to add your specific punbb version number not all the previous version numbers.

ie:  $punbb_versions    = array('1.2.3', '1.2.4', '1.2.5', '1.2.6', '1.2.14');  this isn't your problem, just something i noticed.

@elbekko: will that comma cause the error?

~James
FluxBB - Less is more

16 (edited by Frank H 2006-12-13 18:57)

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

there is only a start ' at the numbers aswell, causing really odd strings ... but elbekkos line should work

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

That was what I corrected Frank, the comma wouldn't have caused any error wink

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

#---------[ 7. FIND (line:620) ]---------------------------------------------------
#

<tr>
        <th scope="row">Use forum rules</th>

#
#---------[ 8. BEFORE, ADD ]---------------------------------------------------
#

<tr>
    <th scope="row">Image Verify registrations</th>
    <td>
        <input type="radio" name="form[regs_verify_image]" value="1"<?php if ($pun_config['o_regs_verify_image'] == '1') echo ' checked="checked"' ?> /> <strong>Yes</strong>   <input type="radio" name="form[regs_verify_image]" value="0"<?php if ($pun_config['o_regs_verify_image'] == '0') echo 'checked="checked"' ?> /> <strong>No</strong>
        <span>When enabled, users are forced to match text with an image in order to register. This is an effective way of avoiding registration abuse and not forcing all users to verify via email which can be time consuming.</span>
    </td>
</tr>

#

what am i meant to do? "before, add" <<< someone please explain?

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

Before the code given in instruction 7, add the code in instruction 8.

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

yeah i thought it meant that, was just checking that's all. thanks.

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

hey

the verification image has installed ok but i just have one little problem though, because i changed the width of my whole forum, now in the admin panel i'm getting this because the mod isnt set to 800 width (i think) i don't know ..  http://i101.photobucket.com/albums/m72/Chris_Powell/adminpanel.jpg

just a little out of place that's all.

everything else seems fine though. thanks.

i could do with getting the above mentioned to look right though, if possible?

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

Looks like you added the text after instead of before

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

i didn't think of doing it that way sad

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

can't i fix this problem now? hmm

Re: [HOWTO] - Upgrade mod compatibility for 1.2.*

Undo what you did and follow the instructions properly wink

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize