Topic: SEF URL problem

Hi folks, sorry my first post is asking for help but here goes.

note: running version 1.3.6 - forum is here -

I recently tried to configure the SEF URLs on my punbb forum. i created a blank htaccess and made sure it was writable,  but straight away everything 404d.

Thinking this might be something to do with my cache, I cleared it in the hope that this problem would then be solved.

I was wrong. The problem still existed and what made matters worse...I was logged out of my forum and could no longer get back into the admin panel to change back as I was getting a 404.

I have tired manually resetting the SEF option in my database, but have had no luck.

If anyone can help me solve the issue, or just tell me how to reset the urls manually it would be very much appreciated!

I look forward to hearing your replies

Thanks a lot!  smile

Re: SEF URL problem

I am just gonna quote what punBB says about this

WARNING! If you select any scheme other than the default scheme you must copy/rename the file .htaccess.dist to .htaccess in the forum root directory. The server that hosts the forums must be configured with mod_rewrite support and must allow the use of .htaccess files. For servers other than Apache, please refer to your servers documentation.

Try that.

Re: SEF URL problem

Hi Matt, thanks for the reply! I had already put a htaccess file in place and changed the permissions to 777, but still I have the problems.

Never had any issues with htaccess files before with hostgator, so not sure its the problem.

Re: SEF URL problem

Could you paste the contents of your .htaccess file. Maybe we can figure it out.

Re: SEF URL problem

Looks like this is where the problem could be, there is absolutely nothing in the htaccess file.

Maybe someone can give me the code that's supposed to be in there for using folder based SEFs?

Thanks again for the reply

Re: SEF URL problem


<IfModule mod_rewrite.c>
# MultiViews interfers with proper rewriting
Options -MultiViews

RewriteEngine On

# Uncomment and properly set the RewriteBase if the rewrite rules are not working properly
#RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . rewrite.php [L]


Re: SEF URL problem

It works!! smile

Thanks a lot for the help, really appreciate it