Topic: Can't post anything

I can't post with error as below :

File: /home/ngocviet/domains/ngocviet.org/public_html/forum/include/search_idx.php
Line: 132

PunBB reported: Unable to fetch search index words

Database reported: Illegal mix of collations for operation ' IN ' (Errno: 1271)

Please help me. Thanks in advance.

Re: Can't post anything

For some reason, you have mixed collations for different tables in your PunBB database. This is not something that happens on its own.

"Programming is like sex: one mistake and you have to support it for the rest of your life."

Re: Can't post anything

Rickard wrote:

For some reason, you have mixed collations for different tables in your PunBB database. This is not something that happens on its own.

I have a same problem. Just checked - all tables have same collation . latin1_swedish_ci, and in language common.php encoding = uft-8

anyone can help me?

Thanks in advance !!

Re: Can't post anything

Moved to Troubleshooting

http://fluxbb.org

Free PunBB Hosting - lots of mods, easy to customize

Re: Can't post anything

misscolombo wrote:
Rickard wrote:

For some reason, you have mixed collations for different tables in your PunBB database. This is not something that happens on its own.

I have a same problem. Just checked - all tables have same collation . latin1_swedish_ci, and in language common.php encoding = uft-8

anyone can help me?

Thanks in advance !!

I try to test different situations:

èèèèèèèèèè - it is ok, the post is registered
aaaaaaaaaa - it is ok

aèaèaèaèaèaèa . "unable to fetch..."

Any idea?

6

Re: Can't post anything

I have the same problem here:

"An error was encountered
Error: Unable to fetch search index words."

My version is: 1.2.12 and the url is http://familiabuchmann.isgreat.org/gene … ?mod=punbb

It happens just when using brazilian portuguese characters like: é á ã ç ó. When a user try to insert a topic or a reply, without these characters, the system works fine.

All my sql's table statement are: UTF-8.

Please, help me to correct this problem quickly. I set my forum as "maintenance" for this reason... anyone can post in brazilian portuguese, our mother language.

Another problem: "Rebuild index" and "Update forum sequence (0, 1, 2)" aren't working. When clicking it opens another strange page (not error) and the rebuild or sequece foruns update didn't happen.

Thanks again,


Bukbr

Re: Can't post anything

I created 2 discussions, because I believed that there were 2 problems. But the cause of 2 was the same - the Search table in database.

Here are 2 discussions:
http://punbb.org/forums/viewtopic.php?id=16365 (mine)
and
http://punbb.org/forums/viewtopic.php?id=9146
I found the solution in coolhd's post (about chineese caracters) - the WORD line in search_words table has to be changed from Varchar to Varbinary.

For me - it works!

8

Re: Can't post anything

Misscolombo, thanks for answering so fast! Your solution worked fine! I thank you very much.

Friends, and could you tell me something about the other error?

"Rebuild index" and "Update forum sequence (0, 1, 2)" aren't working. When clicking it opens another strange page (not error) and the rebuild or sequece foruns update didn't happen.

Thanks.


bukbr