Topic: PunBB 1.3.3

PunBB 1.3.3 is released. 1.3.2 to 1.3.3 changes:

  • a lot of bugs fixed (CSS & markup, defects in language files, correct response header placement upon errors, hook rearrangements, parsing posts in feeds, correct language pack detection during the final stage of the install process);

  • contains fixes of security flaws (which were fixed by hotfixes in previous versions);

  • it is now possible to limit searches to topic subjects or message bodies;

  • users are not allowed to change their e-mails without entering their passwords first.

The already existing styles and language packs should be checked for compatibility with the version 1.3.3 before the latter is installed. After checking, the version 1.3.3 may be installed.

How to upgrade:

  • make a backup of the database and files;

  • turn the Maintenance mode on (via admin panel);

  • overwrite old files with new ones;

  • after owerwriting, verify that cache, img/avatars and extensions (for pun_repository) directories have enough write permissions (usually 777);

  • clear cache directory;

  • go to the forum index and run db_update.php script;

  • turn the Maintenance mode off.

To developers' notice. Please, check your extensions, styles and language packs for compatibility with the version 1.3.3. The following may be of use to you:

Downloads: get the latest PunBB on Downloads page or via Subversion repository.

Re: PunBB 1.3.3

oh my god!

3

Re: PunBB 1.3.3

Parpalak wrote:

PunBB 1.3.3 is released. 1.3.2 to 1.3.3 changes:

  • a lot of bugs fixed (CSS & markup, defects in language files, correct response header placement upon errors, hook rearrangements, parsing posts in feeds, correct language pack detection during the final stage of the install process;

  • contains fixes of security flaws (which were fixed by hotfixes in previous versions);

  • it is now possible to limit searches to topic subjects or message bodies;

  • users are not allowed to change their e-mails without entering their passwords first.

The already existing styles and language packs should be checked for compatibility with the version 1.3.3 before the latter is installed. After checking, the version 1.3.3 may be installed.

How to upgrade:

  • make a backup of the database and files;

  • turn the Maintenance mode on (via admin panel);

  • overwrite old files with new ones;

  • after owerwriting, verify that cache, img/avatars and extensions (for pun_repository) directories have enough write permissions (usually 777);

  • clear cache directory;

  • go to the forum index and run db_update.php script;

  • turn the Maintenance mode off.

To developers' notice. Please, check your extensions, styles and language packs for compatibility with the version 1.3.3. The following may be of use to you:

Downloads: get the latest PunBB on Downloads page or via Subversion repository.


i've done that, but the web now completely blank ..... what did go wrong ???

Re: PunBB 1.3.3

no changed files package? i thought it would be one click upgrade wink.

Re: PunBB 1.3.3

I look forward to hearing reports about what extensions work or don't work with this upgrade. Should there be many issues expected?

6 (edited by Parpalak 2009-04-18 11:57)

Re: PunBB 1.3.3

rajuru wrote:

no changed files package? i thought it would be one click upgrade wink.

You can find packages with changed files in the download archive. Though they will not be very useful since there are many files with changed copyright year only.

db_update.php is to be run during the upgrade. You have to turn maintenance mode on, otherwise anyone can run db_update.php.

Re: PunBB 1.3.3

esupergood wrote:

I look forward to hearing reports about what extensions work or don't work with this upgrade. Should there be many issues expected?

Think that no. These could be some extensions dealing with search, moderate and viewtopic pages. Extensions like pun_pm, pun_repository, pun_bbcode, pun_quote should work fine.

8

Re: PunBB 1.3.3

hey,, succesly upgraded. But in 'another way'. these what i do :

i've backup the database, then upload the 1.3.3 version, but unfortunetly the config.php was deleted. so error happenend. Then i delete all the files, re unzip the 1.3.2, then instal, run db_update. then unzip 1.3.3 run db_update again. Voila, back to bussines again.

Re: PunBB 1.3.3

first time doing update need help

10 (edited by The Wicked Flea 2009-04-20 14:42)

Re: PunBB 1.3.3

I'm upgrading my 1.3.2 site and getting a very loopy error.  When I run db_update via the admin panel (with fancy directory routing on) I get the following error:

An error was encountered

Your PunBB database is out-of-date and must be upgraded in order to continue. Please run db_update.php in order to complete the upgrade process.

Of course, since I got the error by running the db_update there's nothing I can do.  (I don't think the script is timing out.)


Edit:

I'll leave this here for anyone else who encounters the trouble, but this comes from not clearing the cache directory.  I thought that came after the upgrade, though I can't see how I got this idea. roll

11

Re: PunBB 1.3.3

I upgraded but failed to notice there were so many changes done to the CSS, it messed up everything horribly style wise, so I downgraded. I'll have to sit down and code the CSS all over again to match the new changes. Thanks for posting the CSS changes that were done, that's gonna be an essential resource.

12

Re: PunBB 1.3.3

Do we need to update our main.tpl files or can we keep those in the directory?

forum, Art, Architecture

Did you visit the textpattern forum?

Re: PunBB 1.3.3

No changes in templates were made after the release of 1.3.2.

14

Re: PunBB 1.3.3

Can i have full change list currently hawing many custom stuff in forum so can't upgrade sad

15 (edited by Slavok 2009-04-29 08:28)

Re: PunBB 1.3.3

Here you can find the list of changes

16 (edited by homerzhu 2009-05-12 14:56)

Re: PunBB 1.3.3

GREAT job!

smile

Re: PunBB 1.3.3

Hello! Can you tell me, please, is this version secure? there is no CAPTCHA during the registration... Is there no need in this?

Re: PunBB 1.3.3

There is no known security bugs in PunBB 1.3.3. If security bugs are reported, we make hotfixes.

You can use pun_antispam official extension to add CAPTCHA (download from extensions repository).

Re: PunBB 1.3.3

Thank you very much! smile

Re: PunBB 1.3.3

You're welcome.

21

Re: PunBB 1.3.3

Thanks for the clarifications. I was just about to post that question.

22

Re: PunBB 1.3.3

Not that I am trying to convert over, but I heard that there was a big problem converting PunBB to the MyBB system.

The problem deals with merging between the two...especially when it comes to the MySQL database.

Has this problem ever been fixed or resolved?

23

Re: PunBB 1.3.3

Merging databases is always a problem, with just about every software that uses databases.

Re: PunBB 1.3.3

fantasma wrote:

oh my god!

Exactly! I share the same sentiment. I'm really glad that the bugs are fixed. I'm looking forward to more updates.

Re: PunBB 1.3.3

bejo wrote:

hey,, succesly upgraded. But in 'another way'. these what i do :

i've backup the database, then upload the 1.3.3 version, but unfortunetly the config.php was deleted. so error happenend. Then i delete all the files, re unzip the 1.3.2, then instal, run db_update. then unzip 1.3.3 run db_update again. Voila, back to bussines again.

I've successfully upgraded using your method. It was very easy. Thank you big_smile